UserGuide: Installation

Difference between revisions from 2016/02/06 15:17 and 2011/07/19 16:14.
{include:subpage userguide}
You successfully downloaded file (from [Main page]) and would like to install it. The only LionWiki requirement to run is PHP >= 4.3.0,PHP, nothing else is needed. InstallationPHP 5.X-7 should be supported. If you have problems which could be caused by old PHP version, you can try LionWiki 3.2.9 which was tested against PHP 4.3.

Installation can be different depending on your server's operating system

!1) Windows
If your site is supposed to run on Windows, installation is trivial. Just copy files to folder and that is it :):):)

!2) Unix systems (like Linux, FreeBSD etc.)
Copy content of the archive to desired destination (FTP perhaps) and make directory "var" [writable|UserGuide: Writable directory].

In case you move your installation, you need to make "var" directory and all its content [writable|UserGuide: Writable directory]. Most file/FTP managers can do that with single action.



!After installation
After installation, try to load the LionWiki installation in your web browser. You should see empty editing form of Main page of your new Wiki. Try to save it, if there are no errors installation was succesful. In that case, take a look at [Configuration|UserGuide: Configuration].

{tags:installation, userguide}